Dodawanie sumowanie godzin

Mamy tutaj taki przykładowy arkusz godzin pracy / grafik miesięczny, z podziałem na 5 dniowy cykl pracy od poniedziałku do piątku. W kolumnie B wprowadzamy godzinę rozpoczęcia pracy, w kolumnie C godzinę zakończenia pracy, natomiast w kolumnie D sumę przepracowanych godzin w ciągu jednego dnia (patrz rysunek 1).
To jest grafik dla osób którzy mają nienormowany czas pracy (ten akurat arkusz przygotowałem dla mojej siostry która pracuje na umowę zlecenie w gabinecie stomatologicznym).

sumowanie czasu pracy

Rys. 1. Grafik godziny pracy

Aby była możliwość operacji na godzinach, w naszym przypadku dodawanie godzin(sumowanie godzin pracy), komórki w których wprowadzamy godziny powinny mieć odpowiedni format.
Jak to zrobić? Zaznaczamy przedział wszystkich komórek w których będziemy wprowadzać godzinę (w tym przykładzie na rysunku 1 są to trzy kolumny B, C, D), z menu podręcznego myszki prawym przyciskiem klikamy Formatuj komórki lub z klawiatury skrót Ctrl + 1, zakładka Liczby i zaznaczamy Czas i wybieramy format czasu np. 13:30 (patrz rysunek 2) i akceptujemy Ok. format komórek godzina

Rys. 2. Formatowanie komórek na czas

Godziny wprowadzamy w formie 8:00, 16:00 itd., w komórce D4 wprowadzamy formułę która policzy ile godzin pracowaliśmy każdego dnia =MOD(C4-B4;1) i klikamy Enter, patrz rysunek 3. Ten sposób liczenia godzin sprawdzi się gdy czas pracy nie przekracza 24 godzin. ile godzin pracy

Rys. 3. Formuła ile godzin pracowaliśmy jednego dnia

Formułę z komórki D4 kopiujemy do wierszy poniżej (najeżdżamy myszką na prawy dolny róg komórki do pojawiania się znaku + i przeciągamy w dół), patrz rysunek 4. powielanie formuły

Rys. 4. Formuła kopiowanie

Teraz dodamy do siebie wszystkie dni przepracowane w miesiącu (sumujemy wszystkie wartości z kolumny D), w tym celu komórce E3, wprowadzamy funkcję w postaci =SUMA(D3:D33) (patrz rysunek 5), wprowadziłem przedział wszystkich 31 dni miesiąca. suma wszystkich dni

Rys. 5.

Ważne komórkę E3 musimy odpowiednio sformatować, aby można było sumować godziny. Zrobimy to w następujący sposób, zaznacz komórkę następnie z klawiatury Ctrl + 1 następnie zakładka Liczby wybieramy Niestandardowe i w pole tekstowe Typ wklejamy tą zawartość [g]:mm;@ (patrz rysunek 6).

niestandardowe ustawienia typ komórki

Rys. 6.

A oto efekt, formuła na bieżąco sumuje ilość przepracowanych godzin.

suma dodawanie godzin

Rys. 7.

Komentarze


Napisz komentarz:

Podpis:


   =  (Antyspam)