Przykłady - jak policzyć komórki które spełniają określony warunek

W tej lekcji pokażę Wam na przykadzie jak policzyć ilość wystąpeń / liczbę wierszy w których wystąpują określone wyrazy, wartości liczbowe (mniejsze lub większe), lub występują inne znaki.

Do tego celu wykorzystam formułę / funkcję =LICZ.JEŻELI

Zasada działania funkcji jest następująca =LICZ.JEŻELI(zakres komórek ; "wzór co mam znaleźć")

Mam tu arkusz / tabelę (patrz rysunek 1) w której jest lista osób przy pomocy formuły policzę ile jest kobiet i ilu mężczyzn na danej liście, później wykonamy inne obliczenia na liczbach.

W komórce E2 wprowadzam formułę w postaci =LICZ.JEŻELI(C2:C14;"Kobieta"), kolejno klikamy Enter i otrzymujemy w komórce wartość / liczbę kobiet w tym przypadku jest to liczba 6. licz ilość wystąpień

Rys. 1. Liczenie ilości wystąpień

Teraz policzymy ilość mężczyzn w tabeli, kształt funkcji będzie bardzo podobny do poprzedniej formuły, do badania użyjemy ten sam przedział komórek C2:C14, natomiast zmianie ulegnie jedynie argument porównania, którego z kolei nie musimy wprowadzać w postaci "Mężczyzna" wystarczy że wskażemy komórkę w której występuje dane słowo, w tym konkretnym przypadku jest to komórka C4 (patrz rysunek 2). A oto formuła: =LICZ.JEŻELI(C2:C14;C4).

liczba wystąpień

Rys. 2. Policz ilości komórek o argumencie

Czwarta kolumna w arkuszu zawiera wiek osób, teraz policzymy ile osób jest przed 30 rokiem życia (patrz rysunek 3).
A oto nasz formuła =LICZ.JEŻELI(D2:D14; "<30"). liczba wystąpień na wiek

Rys. 3. Policz ilości jeżeli liczba mniejsza

Jeżeli np. chcemy w jednej komórce obliczyć ilość kobiet i mężczyzn (użyć więcej a niżeli jeden argument), formułę można zapisać w takiej formie: =LICZ.JEŻELI(C2:C14;"Kobieta")+LICZ.JEŻELI(C2:C14;"Mężczyzna").

Natomiast jak policzyć wszystkie komórki w Excel w których jest jakakolwiek treść? W tym celu można użyć tej formuły: =LICZ.JEŻELI(D2:D14; "*") znak gwiazdki * program Excel traktuje jako symbol wieloznaczny (oprócz liczb).

Kolejny przykład, policz komórki które zawierają trzy znaki =LICZ.JEŻELI(A:A; "???")

Następny przykład, zlicz komórki które zawierają tylko słowo płaca =LICZ.JEŻELI(A:A; "płaca") (nie rozróżnia wielkości liter).

I kolejny przykład, policz komórki w których występuje słowo płaca =LICZ.JEŻELI(A:A; "*płaca*") (nie rozróżnia wielkości liter).

I jeszcze, zwraca ilość komórek rozpoczynających się na literę B a formuła =LICZ.JEŻELI(A:A; "B*") (nie rozróżnia wielkości liter).

Komentarze


Napisz komentarz:

Podpis:


   =  (Antyspam)  

awatar 2018-10-23    z piekła do nieba
Dzięki nawet nie wiecie ile ta wiedza pomogła zaoszczędzić czasu :)