Średnia lub Suma jeżeli spełniony warunek 

W tym przykładzie wykonam obliczenia na danych w arkuszu w których znajdują się pewne wartości liczbowe "zarobki" przypisane do osób, w tym tutorialu posłużę się argumentami w kolumnie C: Kobieta i Mężczyzna.

Obliczę średnią zarobków tylko dla kobiet, natomiast drugi przykład to suma wszystkich zarobków tylko dla mężczyzn.

Licz średnią zarobków dla kobiet, kształt formuły będzie następujący =ŚREDNIA.JEŻELI(C2:C14;"=Kobieta";E2:E14), gdzie przedział w kolumnie C2:C14 porównujemy ze słowem Kobieta, natomiast wartość średnia obliczana jest z przedziału kolumny E2:E14, patrz rysunek 1. krok po kroku kurs z licz średnią

Rys. 1. Dane wyjściowe arkusz Excel, lista z zarobkami w PLN

Oblicz sumę jeżeli w kolumnie C dopasowany będzie wzorzec w postaci słowa Mężczyzna, kształt formuły =SUMA.JEŻELI(C2:C14;"=Mężczyzna";E2:E14) (patrz rysunek 2). krok po kroku kurs z licz średnią

Rys. 2. Operacje na danych Excel SUMA.JEŻELI

A oto wynik działania dwóch powyższych formuł (patrz rysunek 3). Dane w komórkach powinniśmy zamienić na dane walutowe. Jak to zrobić? Zanaczamy obie komórki i lewym klawiszem myszki z menu podręcznego myszki (prawy przycisk myszki) klikamy Formatuj komórki w zakładce liczby wybieramy Walutowe i symbol , efekt na rysunku 4.

kurs formatowanie komórki na PLN

Rys. 3. Formatowanie komórek Excel

Efekt formatowania komórki.

tutorial formatowanie komórki na polski złoty

Rys. 4. Waluta w Excel

Jeżeli mamy więcej argumentów / wartości do porównania formuły możemy dodawać w ten sposób, przykład: =SUMA.JEŻELI(C2:C14;"=Kobieta";E2:E14)+SUMA.JEŻELI(C2:C14;"=Mężczyzna";E2:E14).

Komentarze


Napisz komentarz:

Podpis:


   =  (Antyspam)