Odwołania, pobieranie danych z innych arkuszy w Excel

Program Excel pozwala nam w formułach odnosić się do komórek, zakresów zlokalizowanych w innych arkuszach bądź nawet skoroszytach.

Odwołanie do innego arkusza tworzymy następująco: znak równa się, nazwa arkusza, wykrzyknik, odwołanie do komórki.

Przykład takiego odniesienia: =NazwaArkusza!A3

Jeżeli chcemy połączyć się z arkuszem który jest zapisany w innym skoroszycie musimy dodatkowo w nawiasach kwadratowych dodać nazwę skoroszytu (pod warunkiem że dany skoroszyt jest otwarty).

Przykład odwołania do skoroszytu: =[SkoroszytNazwa.xlsx]NazwaArkusza!A3

Natomiast gdy skoroszyt jest zamknięty musimy dodać dodatkowo ścieżkę do lokalizacji skoroszytu.

Przykład: =C:⁄ProgramyExcel⁄[Skoroszyt.xlsx]Arkusz1!D3

Jeżeli w nazwie skoroszytu bądź arkusza występuje choć jedna spacja, całą ścieżkę musimy otoczyć pojedynczym cudzysłowem.

Np.: ='Arkusz Finasowy'!C3

Np.: ='[Skoroszyt.xlsx]Arkusz Obliczenia'!D3

Np.: ='C:⁄Programy⁄Excel⁄[Skoroszyt.xlsx]Arkusz Rachunki'!B3

Gdy otworzysz skoroszyt który zawiera odwołania zewnętrzne, Excel w oknie dialogowym zada Ci pytanie, jakie czynności ma wykonać:

  • Aktualizuj (pobiera najnowsze wartości);
  • Nie aktualizuj;
  • Pomoc (dodatkowe informacje).

Jak już korzystasz z odwołań do innych arkuszy / skoroszytów, i zmieniasz nazwy tych skoroszytów bądź arkuszy, zmian dokonaj również w odwołaniach, inaczej odniesienia nie zadziałają.

A jak to wygląda w praktyce?

W jednym skoroszycie mamy dwa arkusze o nazwach Arkusz 01 i Arkusz 02 (Arkusz 01 patrz rysunek 1). Obliczymy sumę zarobków z Arkusza 01 i zapiszemy w Arkuszu 02, wyliczymy średnią zarobków dla kobiet i mężczyzn i zapiszemy w Arkuszu 02, wszystkie działania wykonamy przy pomocy odwołań.

pobieranie danych z innego arkusza w excelu
Rys. 1. Arkusz 01

W Arkuszu 02 zapiszemy sumę zarobków z Arkusza 01 z przedziału komórek E2:E14, kształt formuły jest następujący: =SUMA('Arkusz 01'!E2:E14) (patrz rysunek 2).

suma z innego arkusza
Rys. 2. Arkusz 02

Obliczamy średnią zarobków dla kobiet i średnią dla mężczyzn, oczywiście używamy odwołania do innego arkuszu. Użyję w tym celu formuły =ŚREDNIA.JEŻELI (patrz rysunek 3).
Dla kobiet: =ŚREDNIA.JEŻELI('Arkusz 01'!C2:C14;"=Kobieta";'Arkusz 01'!E2:E14)
Dla mężczyzn: =ŚREDNIA.JEŻELI('Arkusz 01'!C2:C14;"=Mężczyzna";'Arkusz 01'!E2:E14)

średnia pobierz z innego arkusza
Rys. 3. Oblicz średnią z innego arkusza

Obszerniej wytłumaczone, jak stosować ŚREDNIA.JEŻELI i SUMA.JEŻELI.

Komentarze


Napisz komentarz:

Podpis:


   =  (Antyspam)  

awatar 2018-03-05    Ar
Czy możliwe jest zrobienie odwolania do arkusza, który dopiero powstanie. Tak aby po jest stworzeniu w tabeli głównej pojawiły się potrzebne dane automatycznie.